Java は 1.2から Java2 で, 1.4の次は 5.0かよ

今日は,本を買った。 Javaの本だ。

進化するJava J2SE 5.0という本だ。
この本は,新しいJavaの追加機能や変更点の一覧を見ることが出来る。
結構お勧めの本だ。アマゾンのレビュー評価も最高の5つ星なので
すでに,Javaをある程度習得していて,新しいJavaの機能を書籍で勉強したい人にはお勧めだ。


1.4の次が1.5の代わりに 5.0 か。。。まぁ,1.1から1.2にアップしたときも,Java2とか
言って,2.0にしたかったのだろう。

しかし,今回は,1.1から1.2にアップしたときよりもさらに多くの変更点があって,
気持ち,バージョンは2.0ぐらいだ。 しかし,2.0だと, Java2というもので
広めているため,何にも変わっていないと思われてしまう。

かといって,3.0にしてしまうと,何が根拠で,3.0になるのか,答えれないし,
1.4より古く感じる。(4.0だと,1.4の名称を変えただけだと思われるため。)

だから,1.5の変わりに,5.0にするしかない・・・。
話題性やインパクトがないのだ。

と,私は勝手に思っている。。。


この記事へのコメント

この記事へのトラックバック